Performance Degradation on Adsolut.com

Incident Report for Wolters Kluwer Belgium

Resolved

We’ve actively monitored the situation and can confirm that the implemented solution is working as expected. All systems are operational.
Posted Oct 14, 2025 - 08:13 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2025 - 14:21 CEST

Investigating

We are currently experiencing performance issues on Adsolut.com, resulting in slower response times and intermittent availability for some users.
Our technical team is actively investigating the issue. At this time, the full scope of the impact is not yet clear, but we are working to identify and resolve the root cause as quickly as possible.
Updates will be posted both on this page and on our Known Issues page as they become available.
We appreciate your patience and will continue to provide updates as more information becomes available.
Posted Oct 09, 2025 - 11:13 CEST
This incident affected: Adsolut.com.